I'm hoping someone can help please.

I have created a view object and self service page using JDeveloper that uses the view per_assignments_f2, I am using this one because I need to make use of the security profile and assignments being returned. When I run the page in both JDeveloper and also from the server the query returns no rows, the same happens if I use per_assignments_f, but will return data (albeit every assignment) if I use per_all_assignments_f, so I know the query and page will return data and is correct.

The security profile seems to be configured correctly because when I search for an employee using forms, it returns all the 108 correct employees.

I have run my query in SQL and this won't return any data until I run APPS_INTIALIZE setting the APPS session. It is almost as though the OA Framework page is not having the session set so the views don't return any data.

I have also tried select * from per_people_f and again this returned no data.

Does anyone have any ideas on how I can fix this?

I will try raising it with Oracle, but no doubt they will say it's custom code and won't help.

The application is 12.1.3 if that helps

Many thanks